[Checkers] a proposal to rename the Checkers Framework
mernst at csail.mit.edu
Sat May 3 15:23:05 EDT 2008
> The name "Checkers Framework" has been troubling me for a while -- I
> think it's partly because we never really named it, but just
> capitalized its description. As a new and (hopefully) improved name, I
> hereby propose "CFJ", which I suppose stands for both "a Checkers
> Framework for Java" and "Checkers and Framework for Java". Thoughts?
I'm not wild about this name, because it is both unpronounceable and gives
no indication of what it does. By contrast, JavaCOP and JQual are both
pronounceable. COP is both "constraints on programs" and has a pun with a
police cop that prevents you from doing wrong. JQual puts a key idea --
type qualifiers -- in the name.
More information about the checkers