[Checkers] Checkers naming
mernst at csail.mit.edu
Sat May 3 18:02:44 EDT 2008
I've been thinking about names, too. I don't like Checkers Framework,
either, but had a more modest proposal of changing it to Checker Framework
(singular instead of plural). I'm open to bigger changes, though.
Also, I would like to propose changing the name of the NonNull checker.
(We could do this in the next release as well, but that's not as critical
as choosing a new name.) NonNull is a type qualifier, not a checker
name, and we don't expect people to even use that type qualifier in
general. I like "null dereference checker", or NullDeref checker. (An
alternative is "nullness checker", but that isn't as specific about what
the checker actually checks.)
More information about the checkers