[Checkers] romaybe => ropoly?

Matt Papi mpapi at csail.mit.edu
Sun Apr 6 13:11:39 EDT 2008

Personally, I think I'd want the "poly" part to stand out over the
"ro" part, so I'd prefer something like "polyro". (Either way, though,
I think "poly" is superior to "maybe".)

- Matt

On Sat, Apr 5, 2008 at 11:19 AM, Michael Ernst <mernst at csail.mit.edu> wrote:
> Jaime and Telmo-
>  The name "romaybe" was intended to intuitively indicate that the actual
>  argument might be either mutable or readonly (it's "maybe" readonly).
>  However, I'm not sure that the English word "maybe" clearly indicates this
>  meaning.  In papers and documentation, we explain romaybe by explaining
>  that it offers parametric polymorphism over mutability.  Thus, I have been
>  thinking that perhaps we should rename the keyword from "romaybe" to
>  "ropoly".  (And if a similar mechanism were introduced in, for example, the
>  nonnull checker, it would be "nnpoly" instead of "nnmaybe".)  What do you
>  think?
>                     -Mike
>  _______________________________________________
>  checkers mailing list
>  checkers at lists.csail.mit.edu
>  https://lists.csail.mit.edu/mailman/listinfo/checkers

More information about the checkers mailing list