[Checkers] romaybe => ropoly?
mernst at csail.mit.edu
Sat Apr 5 11:19:01 EDT 2008
Jaime and Telmo-
The name "romaybe" was intended to intuitively indicate that the actual
argument might be either mutable or readonly (it's "maybe" readonly).
However, I'm not sure that the English word "maybe" clearly indicates this
meaning. In papers and documentation, we explain romaybe by explaining
that it offers parametric polymorphism over mutability. Thus, I have been
thinking that perhaps we should rename the keyword from "romaybe" to
"ropoly". (And if a similar mechanism were introduced in, for example, the
nonnull checker, it would be "nnpoly" instead of "nnmaybe".) What do you
More information about the checkers