[Jsr308-statements] JSR-308 Statements document update
(discussion items and grammar changes)
Trevor Harmon
trevor at vocaro.com
Wed Apr 18 04:46:07 EDT 2007
On Apr 17, 2007, at 5:57 PM, Michael Ernst wrote:
>> In section "New Class File Attributes" [3], we need to decide if we
>> should use separate Runtime*StatementAnnotations or can reuse common
>> Runtime*TypeAnnotations attribute described in the main jsr308
>> spec [4]
>> and use special target_type value for statement/block annotations.
>
> I have a slight preference for the latter, to avoid a proliferation of
> attributes. (Perhaps others will have a different opinion,
> though.) We
> can change the name from "Type" to "Extended" (or some other bland,
> less
> descriptive name) if you like.
I don't think it would be a problem to add extra attributes. I'd
rather see too many attributes than one attribute playing too many
roles. I feel that if type annotation attributes are mixed together
with statement annotation attributes, the resulting structure may be
overly complex.
Would it be possible to get by with just two attributes? How about
Runtime*TypeAnnotations and a separate one just for statements:
Runtime*StatementAnnotations?
Trevor
More information about the JSR308-statements
mailing list