[Checkers] Checkers Names
mernst at csail.mit.edu
Fri Jun 6 02:58:56 EDT 2008
> Should we change the name of the checkers for this release:
> InternedChecker --> InterningChecker, NonNullChecker -->
> NullnessChecker ?
> Should we change the package names too: checkers.nonnull ->
I think we should do this, but not for this release.
I didn't realize it wasn't already done or planned.
> I noticed interned having the qualified name
> 'checkers.nonnull.quals.Interned'. I assume that was a typo. Should
> it have been in 'checkers.interned.quals.Interned' or interning?
Sorry for the typo. Eventually the package name should be "interning".
> I am a bit concerned about making such changes that affect the user
> significantly without having them in a development release first.
I am not convinced that a development release will help with that. Do we
have any evidence that people are downloading the development release and
sending us bugs based on it?
Better is to make public releases frequently (so that we can react quickly
to bugs), and actually announce them. I don't think that the last one was
ever announced, and I don't want development release to be an excuse for
not doing careful testing.
More information about the checkers