mernst at csail.mit.edu
Tue Jun 24 22:21:13 EDT 2008
My suggestion for refactoring @DefaultQualifier was a bad one.
Please don't change @DefaultQualifier in that way.
Instead, please add a new @DefaultQualifiers annotation that takes as its
argument an array of @DefaultQualifier annotations. The syntax should be
something like this:
Sorry for the design change, but I think this is much clearer for users
than passing in two arrays. It does require that the framework handle both
kinds of annotations (@DefaultQualifier and @DefaultQualifiers), but I
think that's an acceptable tradeoff.
More information about the checkers